Every public CVE, as it is published
The whole CVE List, enriched with NVD scores, CISA's known exploited catalog and EPSS exploit probabilities. Updated every few minutes; last read 1 min ago.
At a glance
Published CVEs; rejected ones are not counted.
- 400,364All CVEsplus 18,889 rejected
- 392Last 24 hours2,992 in the last 7 days
- 17,353Last 30 days1,588 of them critical
- 1,767Known exploitedin the CISA KEV catalog
CVEs published per year
All time, by publication date in UTC; follows the filter above.
- Critical
- High
- Medium
- Low
- Not scored
Show the numbers as a table
| Period | Critical | High | Medium | Low | Not scored | Total | Cumulative |
|---|---|---|---|---|---|---|---|
| 2026 | 0 | 6 | 6 | 0 | 0 | 12 | 20 |
| 2025 | 0 | 0 | 0 | 0 | 0 | 0 | 8 |
| 2024 | 0 | 0 | 0 | 0 | 0 | 0 | 8 |
| 2023 | 0 | 0 | 0 | 0 | 0 | 0 | 8 |
| 2022 | 0 | 0 | 0 | 0 | 0 | 0 | 8 |
| 2021 | 0 | 0 | 0 | 0 | 0 | 0 | 8 |
| 2020 | 0 | 0 | 0 | 0 | 0 | 0 | 8 |
| 2019 | 0 | 3 | 1 | 1 | 0 | 5 | 8 |
| 2018 | 0 | 0 | 0 | 0 | 0 | 0 | 3 |
| 2017 | 1 | 2 | 0 | 0 | 0 | 3 | 3 |
| Title | ||
|---|---|---|
| CVE-2026-120067 | psqlODBC stack buffer overflow copying ctid and oid values for updatable cursorsPostgreSQL · psqlODBC | Medium5.9 |
| CVE-2026-120066 | psqlODBC log files are created with default permissions at a predictable path and follow symbolic linksPostgreSQL · psqlODBC | Medium5.3 |
| CVE-2026-120065 | psqlODBC does not escape a server-supplied column name in its updatable-cursor queriesPostgreSQL · psqlODBC | High7.1 |
| CVE-2026-120064 | psqlODBC does not validate column numbers and row indexes in binding and descriptor functionsPostgreSQL · psqlODBC | High7.5 |
| CVE-2026-120063 | psqlODBC stack buffer overflow when quoting long schema and table namesPostgreSQL · psqlODBC | Medium5.9 |
| CVE-2026-120062 | psqlODBC SQL injection through SQLSpecialColumns table and schema namesPostgreSQL · psqlODBC | High7.5 |
| CVE-2026-120061 | psqlODBC ODBC escape parser stack buffer overflowPostgreSQL · psqlODBC | High7.5 |
| CVE-2026-120060 | psqlODBC does not validate server-supplied counts and lengthsPostgreSQL · psqlODBC | Medium5.9 |
| CVE-2026-120059 | psqlODBC uses a server-supplied column name as a format stringPostgreSQL · psqlODBC | Medium6.8 |
| CVE-2026-120058 | psqlODBC row cache overflow when a later FETCH changes the column countPostgreSQL · psqlODBC | High7.5 |
| CVE-2026-120057 | psqlODBC large-object read overflows the application bufferPostgreSQL · psqlODBC | High7.5 |
| CVE-2026-109448 | psqlODBC SQLBindParameter heap memory corruption when binding more than 32767 parametersPostgreSQL · psqlODBC | Medium5.9 |
| CVE-2019-10211 | Postgresql Windows installer before versions 11.5, 10.10, 9.6.15, 9.5.19, 9.4.24 is vulnerable via bundled OpenSSL executing code from unprotected directory.PostgreSQL · postgresql | High7.8 |
| CVE-2019-10208 | A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where…PostgreSQL · postgresql | High7.5 |
| CVE-2019-10209 | Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.PostgreSQL · postgresql | Low3.1 |
| CVE-2019-10210 | Postgresql Windows installer before versions 11.5, 10.10, 9.6.15, 9.5.19, 9.4.24 is vulnerable via superuser writing password to unprotected temporary file.PostgreSQL · postgresql | Medium6.7 |
| CVE-2019-10164 | PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack-based buffer overflow. Any authenticated user can overflow a…PostgreSQL · PostgreSQL | High7.5 |
| CVE-2017-7548 | PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers with no privileges on a large…PostgreSQL · postgresql | High7.5 |
| CVE-2017-7547 | PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve…PostgreSQL · postgresql | High8.8 |
| CVE-2017-7546 | PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to incorrect authentication flaw allowing remote attackers to gain access to…PostgreSQL · postgresql | Critical9.8 |