Skip to content
CVE Tracker
Back

CVE-2011-10043

Module::Load versions before 0.22 for Perl allow arbitrary modules outside of @INC to be loaded

Critical9.8EPSS 0.78%
Published
Updated
Reserved
Assigned by
CPANSec

Description

Module::Load versions before 0.22 for Perl allow arbitrary modules outside of @INC to be loaded. Module names starting with "::" could be passed to the load function to specify arbitrary module paths. Attackers able to influence module names passed to load could use that bug to execute arbitrary code.

Scores

CVSS scores of CVE-2011-10043, by who scored it
Scored byCVSSScoreVector
CISA-ADPADP (enrichment)3.1Critical9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVDNVD · Deferred3.1Critical9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
0.78% · top 44% of all CVEs (2 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: yes · Technical impact: total

Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.8.

Weakness

Affected products

  • BINGOS · Module::Load

    • affected < 0.22

What to do

Solution: If you are using Perl v5.15.3 or earlier, then upgrade to Module::Load 0.22 or later. Perl versions after v5.15.4 include newer versions of Module::Load that fix this issue.

References (3)

Sources

The same CVE in the primary databases and aggregators, to check against.

Record last updated .