Skip to content
CVE Tracker
Back

CVE-2012-10015

BestWebSoft Twitter Plugin Settings Page twitter.php twttr_settings_page cross-site request forgery

Medium4.3EPSS 0.43%
Published
Updated
Reserved
Assigned by
VulDB

Description

A vulnerability was found in BestWebSoft Twitter Plugin up to 2.14 on WordPress. It has been classified as problematic. Affected is the function twttr_settings_page of the file twitter.php of the component Settings Page. The manipulation leads to cross-site request forgery. It is possible to launch the attack remotely. Upgrading to version 2.15 is able to address this issue. The patch is identified as a6d4659cbb2cbf18ccb0fb43549d5113d74e0146. It is recommended to upgrade the affected component. VDB-230154 is the identifier assigned to this vulnerability.

Scores

CVSS scores of CVE-2012-10015, by who scored it
Scored byCVSSScoreVector
VulDBCNA (assigner)3.1Medium4.3CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
VulDBCNA (assigner)3.0Medium4.3CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
VulDBCNA (assigner)2.0Medium5.0AV:N/AC:L/Au:N/C:N/I:P/A:N
NVDNVD · Modified3.1High8.8CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
0.43% · top 62% of all CVEs (2 Nov 2026)

Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.3.

Weakness

Affected products

  • BestWebSoft · Twitter Plugin

    • affected 2.0
    • affected 2.1
    • affected 2.2
    • affected 2.3
    • affected 2.4
    • affected 2.5
    • affected 2.6
    • affected 2.7
    • affected 2.8
    • affected 2.9
    • affected 2.10
    • affected 2.11
    • affected 2.12
    • affected 2.13
    • affected 2.14

References (3)

Sources

The same CVE in the primary databases and aggregators, to check against.

Record last updated .