CVE-2015-10009
nterchange code_caller_controller.php getContent code injection
- Published
- Updated
- Reserved
- Assigned by
- VulDB
Description
A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VulDBCNA (assigner) | 3.1 | Medium5.5 | CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L |
| VulDBCNA (assigner) | 3.0 | Medium5.5 | CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L |
| VulDBCNA (assigner) | 2.0 | Medium5.2 | AV:A/AC:L/Au:S/C:P/I:P/A:P |
| NVDNVD · Modified | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.94% · top 39% of all CVEs (6 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.5.
Weakness
Affected products
nterchange
- affected 4.0
- affected 4.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Packagistnonfiction/nterchangeGHSA-cp2p-6xh4-jmcp (opens in a new tab)
References (4)
- https://vuldb.com/?id.217187 (opens in a new tab)vdb-entrytechnical-descriptionx_transferred
- https://vuldb.com/?ctiid.217187 (opens in a new tab)signaturepermissions-requiredx_transferred
- https://github.com/nonfiction/nterchange_backend/commit/fba7d89176fba8fe289edd58835fe45080797d99 (opens in a new tab)patchx_transferred
- https://github.com/nonfiction/nterchange_backend/releases/tag/4.1.1 (opens in a new tab)patchx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-cp2p-6xh4-jmcp (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2015-10009)Record last updated .