Back
CVE-2015-10094
Fastly Plugin api.php post cross site scripting
Low2.4EPSS 0.55%
- Published
- Updated
- Reserved
- Assigned by
- VulDB
Description
A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VulDBCNA (assigner) | 3.1 | Low2.4 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N |
| VulDBCNA (assigner) | 3.0 | Low2.4 | CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N |
| VulDBCNA (assigner) | 2.0 | Low3.3 | AV:N/AC:L/Au:M/C:N/I:P/A:N |
| NVDNVD · Modified | 3.1 | Medium6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.55% · top 54% of all CVEs (5 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 2.4.
Weakness
Affected products
Fastly Plugin
- affected 0.1
- affected 0.2
- affected 0.3
- affected 0.4
- affected 0.5
- affected 0.6
- affected 0.7
- affected 0.8
- affected 0.9
- affected 0.10
- affected 0.11
- affected 0.12
- affected 0.13
- affected 0.14
- affected 0.15
- affected 0.16
- affected 0.17
- affected 0.18
- affected 0.19
- affected 0.20
- affected 0.21
- affected 0.22
- affected 0.23
- affected 0.24
- affected 0.25
- affected 0.26
- affected 0.27
- affected 0.28
- affected 0.29
- affected 0.30
- affected 0.31
- affected 0.32
- affected 0.33
- affected 0.34
- affected 0.35
- affected 0.36
- affected 0.37
- affected 0.38
- affected 0.39
- affected 0.40
- and 57 more
References (4)
- https://vuldb.com/?id.222326 (opens in a new tab)vdb-entrytechnical-descriptionx_transferred
- https://vuldb.com/?ctiid.222326 (opens in a new tab)signaturepermissions-requiredx_transferred
- https://github.com/wp-plugins/fastly/commit/d7fe42538f4d4af500e3af9678b6b06fba731656 (opens in a new tab)patchx_transferred
- https://github.com/wp-plugins/fastly/releases/tag/0.98 (opens in a new tab)patchx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2015-10094)Record last updated .