Back
CVE-2017-12614
It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS…
Medium6.1EPSS 2.0%
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.0 | Medium6.1 | CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 2.0% · top 19% of all CVEs (5 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.1.
Weakness
- XSS Vulnerability
- CWE-79 (opens in a new tab)All about CWE-79 and its CVEs
Affected products
Apache Software Foundation · Apache Airflow
- affected < 1.9.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- PyPIapache-airflowGHSA-rv25-9wgj-xg75 (opens in a new tab)
References (1)
- [dev] 20180806 CVE-2017-12614 XSS Vulnerability in Airflow < 1.9 (opens in a new tab)mailing-listx_refsource_MLISTx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-rv25-9wgj-xg75 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2017-12614)Record last updated .