CVE-2017-20158
vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting
- Published
- Updated
- Reserved
- Assigned by
- VulDB
Description
** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VulDBCNA (assigner) | 3.1 | Low3.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N |
| VulDBCNA (assigner) | 3.0 | Low3.5 | CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N |
| VulDBCNA (assigner) | 2.0 | Medium4.0 | AV:N/AC:L/Au:S/C:N/I:P/A:N |
| NVDNVD · Modified | 3.1 | Medium6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.60% · top 51% of all CVEs (4 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 3.5.
Weakness
Affected products
- affected 0.1.0
- affected 0.1.1
- affected 0.1.2
- affected 0.1.3
- affected 0.1.4
- affected 0.1.5
- affected 0.1.6
- affected 0.1.7
- affected 0.1.8
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Packagistvova07/yii2-fileapi-widgetGHSA-j82x-fh8h-326g (opens in a new tab)
References (4)
- https://vuldb.com/?id.217141 (opens in a new tab)vdb-entrytechnical-descriptionx_transferred
- https://vuldb.com/?ctiid.217141 (opens in a new tab)signaturepermissions-requiredx_transferred
- https://github.com/vova07/yii2-fileapi-widget/commit/c00d1e4fc912257fca1fce66d7a163bdbb4c8222 (opens in a new tab)patchx_transferred
- https://github.com/vova07/yii2-fileapi-widget/releases/tag/0.1.9 (opens in a new tab)patchx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-j82x-fh8h-326g (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2017-20158)Record last updated .