Skip to content
CVE Tracker
Back

CVE-2017-20175

DaSchTour matomo-mediawiki-extension Username Piwik.hooks.php cross site scripting

Low2.6EPSS 0.61%
Published
Updated
Reserved
Assigned by
VulDB

Description

A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The patch is named 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.

Scores

CVSS scores of CVE-2017-20175, by who scored it
Scored byCVSSScoreVector
VulDBCNA (assigner)3.1Low2.6CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N
VulDBCNA (assigner)3.0Low2.6CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N
VulDBCNA (assigner)2.0Low2.1AV:N/AC:H/Au:S/C:N/I:P/A:N
NVDNVD · Modified3.1Medium6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS (exploitation in 30 days)
0.61% · top 51% of all CVEs (2 Nov 2026)

Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 2.6.

Weakness

Affected products

  • DaSchTour · matomo-mediawiki-extension

    • affected 2.4.0
    • affected 2.4.1
    • affected 2.4.2

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (5)

Sources

The same CVE in the primary databases and aggregators, to check against.

Record last updated .