Back
CVE-2018-25031
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an…
Medium4.3EPSS 42.3%
- Published
- Updated
- Reserved
- Assigned by
- mitre
Description
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | Medium4.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N |
| NVDNVD · Modified | 3.1 | Medium4.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N |
- EPSS (exploitation in 30 days)
- 42.3% · top 1.3% of all CVEs (5 Nov 2026)
- CISA SSVC
- Exploitation: poc · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.3.
Weakness
Affected products
n/a
- affected n/a
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.webjars:swagger-uiGHSA-cr3q-pqgq-m8c2 (opens in a new tab)
- npmswagger-uiGHSA-cr3q-pqgq-m8c2 (opens in a new tab)
References (4)
- https://security.snyk.io/vuln/SNYK-JS-SWAGGERUI-2314885 (opens in a new tab)x_transferred
- https://github.com/swagger-api/swagger-ui/issues/4872 (opens in a new tab)x_transferred
- https://github.com/swagger-api/swagger-ui/releases/tag/v4.1.3 (opens in a new tab)x_transferred
- https://security.netapp.com/advisory/ntap-20220407-0004/ (opens in a new tab)x_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-cr3q-pqgq-m8c2 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2018-25031)Record last updated .