CVE-2018-25088
Blue Yonder postgraas_server PostgreSQL Backend postgres_cluster_driver.py create_postgres_db sql injection
- Published
- Updated
- Reserved
- Assigned by
- VulDB
Description
A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2. Affected is the function _create_pg_connection/create_postgres_db of the file postgraas_server/backends/postgres_cluster/postgres_cluster_driver.py of the component PostgreSQL Backend Handler. The manipulation leads to sql injection. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 7cd8d016edc74a78af0d81c948bfafbcc93c937c. It is recommended to upgrade the affected component. VDB-234246 is the identifier assigned to this vulnerability.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VulDBCNA (assigner) | 3.1 | Medium5.5 | CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L |
| VulDBCNA (assigner) | 3.0 | Medium5.5 | CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L |
| VulDBCNA (assigner) | 2.0 | Medium5.2 | AV:A/AC:L/Au:S/C:P/I:P/A:P |
| NVDNVD · Modified | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.73% · top 45% of all CVEs (6 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.5.
Weakness
Affected products
Blue Yonder · postgraas_server
- affected 2.0.0b2
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- PyPIpostgraas-serverGHSA-vghm-8cjp-hjw6 (opens in a new tab)
References (4)
- https://vuldb.com/?id.234246 (opens in a new tab)vdb-entrytechnical-descriptionx_transferred
- https://vuldb.com/?ctiid.234246 (opens in a new tab)signaturepermissions-requiredx_transferred
- https://github.com/blue-yonder/postgraas_server/commit/7cd8d016edc74a78af0d81c948bfafbcc93c937c (opens in a new tab)patchx_transferred
- https://github.com/blue-yonder/postgraas_server/releases/tag/v2.0.0 (opens in a new tab)patchx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-vghm-8cjp-hjw6 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2018-25088)Record last updated .