Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2018-25160

HTTP::Session2 versions through 1.09 for Perl does not validate the format of user provided session ids, enabling code injection or other impact depending on session backend

Medium6.5EPSS 0.45%
Published
Updated
Reserved
Assigned by
CPANSec

Description

HTTP::Session2 versions through 1.09 for Perl does not validate the format of user provided session ids, enabling code injection or other impact depending on session backend. For example, if an application uses memcached for session storage, then it may be possible for a remote attacker to inject memcached commands in the session id value.

Scores

CVSS scores of CVE-2018-25160, by who scored it
Scored byCVSSScoreVector
CISA-ADPADP (enrichment)3.1Medium6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
NVDNVD · Analyzed3.1Medium6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS (exploitation in 30 days)
0.45% · top 61% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: yes · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.5.

Weakness

Affected products

What to do

Solution: HTTP::Session2 has been deprecated since version 1.11, users are recommended to migrate to a different solution.

Workaround: Upgrade to version 1.10 or later. Use a session storage module that offers protection against command injections, such as Cache::Memcached::Fast::Safe.

References (4)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2018-25160 badge
[![CVE-2018-25160](https://trackcve.app/badge/CVE-2018-25160.svg)](https://trackcve.app/cve/CVE-2018-25160)

Record last updated .