CVE-2018-7602
Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004
- Published
- Updated
- Reserved
- Assigned by
- drupal
Description
A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.
Exploited in the wild
CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as Drupal Core Remote Code Execution Vulnerability.
- Added
- 13 Apr 2022
- Fix due (US federal)
- 4 May 2022
- Used by ransomware
- Known
Apply updates per vendor instructions.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | High8.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Analyzed | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 99.2% · top 0.1% of all CVEs (3 Nov 2026)
- CISA SSVC
- Exploitation: active · Automatable: no · Technical impact: total
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.1.
Weakness
Affected products
Drupal · core
- affected unspecified – < 7.59
- affected unspecified – < 8.5.3
- affected unspecified – < 8.4.8
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Packagistdrupal/coreGHSA-297x-j9pm-xjgg (opens in a new tab)
- Packagistdrupal/drupalGHSA-297x-j9pm-xjgg (opens in a new tab)
What to do
Solution: Solution: Upgrade to the most recent version of Drupal 7 or 8 core. If you are running 7.x, upgrade to Drupal 7.59. If you are running 8.5.x, upgrade to Drupal 8.5.3. If you are running 8.4.x, upgrade to Drupal 8.4.8. (Drupal 8.4.x is no longer supported and we don't normally provide security releases for unsupported minor releases. However, we are providing this 8.4.x release so that sites can update as quickly as possible. You should update to 8.4.8 immediately, then update to 8.5.3 or the latest secure release as soon as possible.) If you are unable to update immediately, or if you are running a Drupal distribution that does not yet include this security release, you can attempt to apply the patch below to fix the vulnerability until you are able to update completely: Patch for Drupal 8.x (8.5.x and below) Patch for Drupal 7.x These patches will only work if your site already has the fix from SA-CORE-2018-002 applied. (If your site does not have that fix, it may already be compromised.)
References (8)
- 44557 (opens in a new tab)exploitx_refsource_EXPLOIT-DBx_transferred
- 1040754 (opens in a new tab)vdb-entryx_refsource_SECTRACKx_transferred
- [debian-lts-announce] 20180426 [SECURITY] [DLA 1365-1] drupal7 security update (opens in a new tab)mailing-listx_refsource_MLISTx_transferred
- 44542 (opens in a new tab)exploitx_refsource_EXPLOIT-DBx_transferred
- DSA-4180 (opens in a new tab)vendor-advisoryx_refsource_DEBIANx_transferred
- https://www.drupal.org/sa-core-2018-004 (opens in a new tab)x_refsource_CONFIRMx_transferred
- 103985 (opens in a new tab)vdb-entryx_refsource_BIDx_transferred
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-7602 (opens in a new tab)government-resource
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- CISA KEV catalog (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-297x-j9pm-xjgg (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Record last updated .