CVE-2019-11580
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send…
- Published
- Updated
- Reserved
- Assigned by
- atlassian
Description
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.
Exploited in the wild
CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability.
- Added
- 3 Nov 2021
- Fix due (US federal)
- 3 May 2022
- Used by ransomware
- Known
Apply updates per vendor instructions.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Analyzed | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 95.4% · top 0.1% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: active · Automatable: yes · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.8.
Weakness
- Leftover Debug Code
- CWE-noinfo Not enough information
Affected products
- affected 2.1.0 – < unspecified
- affected unspecified – < 3.0.5
- affected 3.1.0 – < unspecified
- affected unspecified – < 3.1.6
- affected 3.2.0 – < unspecified
- affected unspecified – < 3.2.8
- affected 3.3.0 – < unspecified
- affected unspecified – < 3.3.5
- affected 3.4.0 – < unspecified
- affected unspecified – < 3.4.4
References (4)
- https://jira.atlassian.com/browse/CWD-5388 (opens in a new tab)x_refsource_MISCx_transferred
- 108637 (opens in a new tab)vdb-entryx_refsource_BIDx_transferred
- http://packetstormsecurity.com/files/163810/Atlassian-Crowd-pdkinstall-Remote-Code-Execution.html (opens in a new tab)x_refsource_MISCx_transferred
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-11580 (opens in a new tab)government-resource
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- CISA KEV catalog (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2019-11580)Record last updated .