CVE-2019-17337
TIBCO Spotfire Server Library Vulnerable to Reflected Cross-Site Scripting
- Published
- Updated
- Reserved
- Assigned by
- tibco
Description
The Spotfire library component of TIBCO Software Inc.'s TIBCO Spotfire Analytics Platform for AWS Marketplace and TIBCO Spotfire Server contains a vulnerability that theoretically allows an attacker to perform a reflected cross-site scripting (XSS) attack. Affected releases are TIBCO Software Inc.'s TIBCO Spotfire Analytics Platform for AWS Marketplace: version 10.6.0 and TIBCO Spotfire Server: versions 7.11.7 and below, versions 7.12.0, 7.13.0, 7.14.0, 10.0.0, 10.0.1, 10.1.0, 10.2.0, 10.2.1, 10.3.0, 10.3.1, 10.3.2, 10.3.3, and 10.3.4, versions 10.4.0, 10.5.0, and 10.6.0.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| tibcoCNA (assigner) | 3.0 | High8.1 | CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N |
| NVDNVD · Modified | 3.1 | Medium5.4 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.73% · top 46% of all CVEs (6 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.1.
Weakness
- The impact of the vulnerability includes the theoretical possibility that an attacker could gain full administrative access to the web interface of the affected component.
- CWE-79 (opens in a new tab)All about CWE-79 and its CVEs
Affected products
TIBCO Software Inc. · TIBCO Spotfire Analytics Platform for AWS Marketplace
- affected 10.6.0
TIBCO Software Inc. · TIBCO Spotfire Server
- affected unspecified – ≤ 7.11.7
- affected 7.12.0
- affected 7.13.0
- affected 7.14.0
- affected 10.0.0
- affected 10.0.1
- affected 10.1.0
- affected 10.2.0
- affected 10.2.1
- affected 10.3.0
- affected 10.3.1
- affected 10.3.2
- affected 10.3.3
- affected 10.3.4
- affected 10.4.0
- affected 10.5.0
- affected 10.6.0
What to do
Solution: TIBCO has released updated versions of the affected components which address these issues. TIBCO Spotfire Analytics Platform for AWS Marketplace version 10.6.0 update to version 10.6.1 or higher TIBCO Spotfire Server versions 7.11.7 and below update to version 7.11.8 or higher TIBCO Spotfire Server versions 7.12.0, 7.13.0, 7.14.0, 10.0.0, 10.0.1, 10.1.0, 10.2.0, 10.2.1, 10.3.0, 10.3.1, 10.3.2, 10.3.3, and 10.3.4 update to version 10.3.5 or higher TIBCO Spotfire Server versions 10.4.0, 10.5.0, and 10.6.0 update to version 10.6.1 or higher
References (2)
- http://www.tibco.com/services/support/advisories (opens in a new tab)x_refsource_MISCx_transferred
- https://www.tibco.com/support/advisories/2019/12/tibco-security-advisory-december-17-2019-tibco-spotfire-2019-17337 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2019-17337)Record last updated .