CVE-2019-3398
Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has…
- Published
- Updated
- Reserved
- Assigned by
- atlassian
Description
Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has permission to add attachments to pages and / or blogs or to create a new space or a personal space or who has 'Admin' permissions for a space can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Confluence Server or Data Center. All versions of Confluence Server from 2.0.0 before 6.6.13 (the fixed version for 6.6.x), from 6.7.0 before 6.12.4 (the fixed version for 6.12.x), from 6.13.0 before 6.13.4 (the fixed version for 6.13.x), from 6.14.0 before 6.14.3 (the fixed version for 6.14.x), and from 6.15.0 before 6.15.2 are affected by this vulnerability.
Exploited in the wild
CISA lists this vulnerability in its Known Exploited Vulnerabilities catalog as Atlassian Confluence Server and Data Center Path Traversal Vulnerability.
- Added
- 3 Nov 2021
- Fix due (US federal)
- 3 May 2022
- Used by ransomware
- Not known
Apply updates per vendor instructions.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | High8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Analyzed | 3.1 | High8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 97.0% · top 0.1% of all CVEs (5 Nov 2026)
- CISA SSVC
- Exploitation: active · Automatable: no · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.8.
Weakness
Affected products
- affected 2.0.0 – < unspecified
- affected unspecified – < 6.6.13
- affected 6.7.0 – < unspecified
- affected unspecified – < 6.12.4
- affected 6.13.0 – < unspecified
- affected unspecified – < 6.13.4
- affected 6.14.0 – < unspecified
- affected unspecified – < 6.14.3
- affected 6.15.0 – < unspecified
- affected unspecified – < 6.15.2
References (7)
- https://jira.atlassian.com/browse/CONFSERVER-58102 (opens in a new tab)x_refsource_MISCx_transferred
- 20190424 Confluence Security Advisory - 2019-04-17 (opens in a new tab)mailing-listx_refsource_BUGTRAQx_transferred
- http://packetstormsecurity.com/files/152616/Confluence-Server-Data-Center-Path-Traversal.html (opens in a new tab)x_refsource_MISCx_transferred
- 108067 (opens in a new tab)vdb-entryx_refsource_BIDx_transferred
- http://packetstormsecurity.com/files/155235/Atlassian-Confluence-6.15.1-Directory-Traversal.html (opens in a new tab)x_refsource_MISCx_transferred
- http://packetstormsecurity.com/files/155245/Atlassian-Confluence-6.15.1-Directory-Traversal.html (opens in a new tab)x_refsource_MISCx_transferred
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-3398 (opens in a new tab)government-resource
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- CISA KEV catalog (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2019-3398)Record last updated .