Back
CVE-2019-6180
A stored cross-site scripting (XSS) vulnerability was reported in Lenovo XClarity Administrator (LXCA) versions prior to 2.5.0 that could…
Medium4.8EPSS 0.65%
- Published
- Updated
- Reserved
- Assigned by
- lenovo
Description
A stored cross-site scripting (XSS) vulnerability was reported in Lenovo XClarity Administrator (LXCA) versions prior to 2.5.0 that could allow an administrative user to cause JavaScript code to be stored in LXCA which may then be executed in the user's web browser. The JavaScript code is not executed on LXCA itself.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| lenovoCNA (assigner) | 3.0 | Medium4.8 | CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N |
| NVDNVD · Modified | 3.1 | Medium4.8 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.65% · top 49% of all CVEs (4 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.8.
Weakness
- code execution
- CWE-79 (opens in a new tab)All about CWE-79 and its CVEs
Affected products
Lenovo · XClarity Administrator (LXCA)
- affected unspecified – < 2.5.0
What to do
Solution: Update your LXCA installation to version 2.5.0 or later.
References (1)
- https://support.lenovo.com/solutions/LEN-27805 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2019-6180)Record last updated .