Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2019-9535

iTerm2, up to and including version 3.3.5, with tmux integration is vulnerable to remote command execution

Critical9.8EPSS 2.5%
Published
Updated
Reserved
Assigned by
certcc

Description

A vulnerability exists in the way that iTerm2 integrates with tmux's control mode, which may allow an attacker to execute arbitrary commands by providing malicious output to the terminal. This affects versions of iTerm2 up to and including 3.3.5. This vulnerability may allow an attacker to execute arbitrary commands on their victim's computer by providing malicious output to the terminal. It could be exploited using command-line utilities that print attacker-controlled content.

Scores

CVSS scores of CVE-2019-9535, by who scored it
Scored byCVSSScoreVector
NVDNVD · Modified3.1Critical9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
2.5% · top 15% of all CVEs (5 Nov 2026)
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.8.

Weakness

Affected products

What to do

Workaround: Update iTerm2 to version 3.3.6, which includes mitigations against exploitation of this vulnerability.

References (3)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2019-9535 badge
[![CVE-2019-9535](https://trackcve.app/badge/CVE-2019-9535.svg)](https://trackcve.app/cve/CVE-2019-9535)

Record last updated .