Back
CVE-2020-11030
Cross-site scripting (XSS) in Search block in WordPress
Medium6.4EPSS 1.4%
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 3.1 | Medium6.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N |
| NVDNVD · Modified | 3.1 | Medium5.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 1.4% · top 27% of all CVEs (7 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.4.
Weakness
Affected products
- affected >= 5.4.0, < 5.4.1
- affected >= 5.3.0, < 5.3.3
- affected >= 5.2.0, < 5.2.6
- affected >= 5.1.0, < 5.1.5
- affected >= 5.0.0, < 5.0.9
- affected >= 4.9.0, < 4.9.14
- affected >= 4.8.0, < 4.8.13
- affected >= 4.7.0, < 4.7.17
- affected >= 4.6.0, < 4.6.18
- affected >= 4.5.0, < 4.5.21
- affected >= 4.4.0, < 4.4.22
- affected >= 4.3.0, < 4.3.23
- affected >= 4.2.0, < 4.2.27
- affected >= 4.1.0, < 4.1.30
- affected >= 4.0.0, < 4.0.30
- affected >= 3.9.0, < 3.9.31
- affected >= 3.8.0, < 3.8.33
- affected >= 3.7.0, < 3.7.33
References (3)
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates (opens in a new tab)x_refsource_MISCx_transferred
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-vccm-6gmc-qhjh (opens in a new tab)x_refsource_CONFIRMx_transferred
- DSA-4677 (opens in a new tab)vendor-advisoryx_refsource_DEBIANx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2020-11030)Record last updated .