Back
CVE-2020-25699
In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles…
High7.5EPSS 1.6%
- Published
- Updated
- Reserved
- Assigned by
- redhat
Description
In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N |
- EPSS (exploitation in 30 days)
- 1.6% · top 24% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.5.
Weakness
Affected products
moodle
- affected Fixed in 3.9.3
- affected Fixed in 3.8.6
- affected Fixed in 3.7.9
- affected Fixed in 3.5.15
- affected Fixed in 3.10
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Packagistmoodle/moodleGHSA-h77r-rp97-7rv4 (opens in a new tab)
References (4)
- https://bugzilla.redhat.com/show_bug.cgi?id=1895425 (opens in a new tab)x_transferred
- https://moodle.org/mod/forum/discuss.php?d=413936 (opens in a new tab)x_transferred
- FEDORA-2020-304aa2c365 (opens in a new tab)vendor-advisoryx_transferred
- FEDORA-2020-db73e37548 (opens in a new tab)vendor-advisoryx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-h77r-rp97-7rv4 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2020-25699)Record last updated .