Back
CVE-2020-4047
Authenticated XSS via media attachment page in WordPress
Medium6.8EPSS 3.3%
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 3.1 | Medium6.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N |
| NVDNVD · Modified | 3.1 | Medium6.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N |
- EPSS (exploitation in 30 days)
- 3.3% · top 12% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.8.
Weakness
Affected products
- affected >= 5.4.0, < 5.4.2
- affected >= 5.3.0, < 5.3.4
- affected >= 5.2.0, < 5.2.7
- affected >= 5.1.0, < 5.1.6
- affected >= 5.0.0, < 5.0.10
- affected >= 4.9.0, < 4.9.15
- affected >= 4.8.0, < 4.8.14
- affected >= 4.7.0, < 4.7.18
- affected >= 4.6.0, < 4.6.19
- affected >= 4.5.0, < 4.5.22
- affected >= 4.4.0, < 4.4.23
- affected >= 4.3.0, < 4.3.24
- affected >= 4.2.0, < 4.2.28
- affected >= 4.1.0, < 4.1.31
- affected >= 4.0.0, < 4.0.31
- affected >= 3.9.0, < 3.9.32
- affected >= 3.8.0, < 3.8.34
- affected >= 3.7.0, < 3.7.34
References (8)
- https://wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/ (opens in a new tab)x_refsource_MISCx_transferred
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-8q2w-5m27-wm27 (opens in a new tab)x_refsource_CONFIRMx_transferred
- https://github.com/WordPress/wordpress-develop/commit/0977c0d6b241479ecedfe19e96be69f727c3f81f (opens in a new tab)x_refsource_MISCx_transferred
- FEDORA-2020-8447a3e195 (opens in a new tab)vendor-advisoryx_refsource_FEDORAx_transferred
- FEDORA-2020-bbedd29391 (opens in a new tab)vendor-advisoryx_refsource_FEDORAx_transferred
- DSA-4709 (opens in a new tab)vendor-advisoryx_refsource_DEBIANx_transferred
- [debian-lts-announce] 20200701 [SECURITY] [DLA 2269-1] wordpress security update (opens in a new tab)mailing-listx_refsource_MLISTx_transferred
- [debian-lts-announce] 20200911 [SECURITY] [DLA 2371-1] wordpress security update (opens in a new tab)mailing-listx_refsource_MLISTx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2020-4047)Record last updated .