Back
CVE-2021-33192
Display information UI XSS
Medium6.1EPSS 2.9%
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | Medium6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 2.9% · top 13% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.1.
Weakness
Affected products
Apache Software Foundation · Apache Jena Fuseki
- affected Apache Jena Fuseki2 2.0.0 to 4.0.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.jena:jena-fusekiGHSA-phwj-86vx-cfjc (opens in a new tab)
What to do
Workaround: Users are advised to upgrade to Apache Jena 4.1.0 or later.
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-phwj-86vx-cfjc (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2021-33192)Record last updated .