Back
CVE-2021-3485
Improper Input Validation in Bitdefender Endpoint Security Tools for Linux
Medium6.4EPSS 0.88%
- Published
- Updated
- Reserved
- Assigned by
- Bitdefender
Description
An Improper Input Validation vulnerability in the Product Update feature of Bitdefender Endpoint Security Tools for Linux allows a man-in-the-middle attacker to abuse the DownloadFile function of the Product Update to achieve remote code execution. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.2.21.155.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| BitdefenderCNA (assigner) | 3.1 | Medium6.4 | CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Modified | 3.1 | Medium6.6 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.88% · top 41% of all CVEs (7 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.4.
Weakness
Affected products
Bitdefender · Endpoint Security Tools for Linux
- affected unspecified – < 6.2.21.155
What to do
Solution: An automatic update to version 6.2.21.155 fixes the issue.
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2021-3485)Record last updated .