CVE-2021-3554
Improper Access Control vulnerability in the patchesUpdate API
- Published
- Updated
- Reserved
- Assigned by
- Bitdefender
Description
Improper Access Control vulnerability in the patchesUpdate API as implemented in Bitdefender Endpoint Security Tools for Linux as a relay role allows an attacker to manipulate the remote address used for pulling patches. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.6.27.390; versions prior to 7.1.2.33. Bitdefender Unified Endpoint versions prior to 6.2.21.160. Bitdefender GravityZone versions prior to 6.24.1-1.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| BitdefenderCNA (assigner) | 3.1 | Critical9.0 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H |
| NVDNVD · Modified | 3.1 | Critical10.0 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 2.1% · top 18% of all CVEs (6 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.0.
Weakness
Affected products
Bitdefender · Endpoint Security Tools for Linux
- affected unspecified – < 6.6.27.390
- affected unspecified – < 7.1.2.33
Bitdefender · Unified Endpoint
- affected unspecified – < 6.2.21.160
- affected unspecified – < 6.24.1-1
What to do
Workaround: An automatic update to version 6.6.27.390 fixes the issue.
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2021-3554)Record last updated .