Back
CVE-2021-36152
Insecure TrustManager used in LDAP connections
Critical9.8EPSS 1.3%
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 1.3% · top 29% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.8.
Weakness
- Insecure TrustManager used in LDAP connections
Affected products
Apache Software Foundation · Apache Gobblin
- affected Apache Gobblin – ≤ 0.15.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.gobblin:gobblin-coreGHSA-q5rx-8c2h-5q7j (opens in a new tab)
References (1)
- https://lists.apache.org/thread/3bxf7rbf4zh95r78jtgth6gwhr5fyl2j (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-q5rx-8c2h-5q7j (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2021-36152)Record last updated .