Description
Apache Superset up to and including 1.3.1 allowed for database connections password leak for authenticated users. This information could be accessed in a non-trivial way.
Timeline
ID reserved
By apache
- 39 days later
· 39 days later
Published
- 3 years later
· 3 years later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | Medium6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N |
- EPSS (exploitation in 30 days)
- 1.5% · top 26% of all CVEs (7 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.5.
Weakness
Affected products
Apache Software Foundation · Apache Superset
- affected Apache Superset – ≤ 1.3.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- PyPIapache-supersetGHSA-42q4-9xf9-f67x (opens in a new tab)
What to do
Workaround: Upgrade to Apache Superset 1.3.2 or higher
References (2)
- https://lists.apache.org/thread/xpdl2r538o695o7r9gd9qrwqb17bdd3v (opens in a new tab)x_refsource_MISCx_transferred
- https://seclists.org/oss-sec/2021/q4/106 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-42q4-9xf9-f67x (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2021-41972)Record last updated .