Back
CVE-2022-1791
One Click Plugin Updater <= 2.4.14 - Arbitrary Settings Update via CSRF
High8.1EPSS 0.53%
- Published
- Updated
- Reserved
- Assigned by
- WPScan
Description
The One Click Plugin Updater WordPress plugin through 2.4.14 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack and disable / hide the badge of the available updates and the related check.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | High8.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.53% · top 55% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.1.
Weakness
Affected products
Unknown · One Click Plugin Updater
- affected 2.4.14 – ≤ 2.4.14
References (1)
- https://wpscan.com/vulnerability/5c185269-cb3a-4463-8d73-b190813d4431 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-1791)Record last updated .