CVE-2022-2155
A vulnerability exists in the Lumada APM’s User Asset Group feature due to a flaw in access control mechanism implementation on the “Limited Engineer” role.
- Published
- Updated
- Reserved
- Assigned by
- Hitachi Energy
Description
A vulnerability exists in the affected versions of Lumada APM’s User Asset Group feature due to a flaw in access control mechanism implementation on the “Limited Engineer” role, granting it access to the embedded Power BI reports feature. An attacker that manages to exploit the vulnerability on a customer’s Lumada APM could access unauthorized information by gaining unauthorized access to any Power BI reports installed by the customer. Furthermore, the vulnerability enables an attacker to manipulate asset issue comments on assets, which should not be available to the attacker. Affected versions * Lumada APM on-premises version 6.0.0.0 - 6.4.0.* List of CPEs: * cpe:2.3:a:hitachienergy:lumada_apm:6.0.0.0:*:*:*:*:*:*:* * cpe:2.3:a:hitachienergy:lumada_apm:6.1.0.0:*:*:*:*:*:*:* * cpe:2.3:a:hitachienergy:lumada_apm:6.2.0.0:*:*:*:*:*:*:* * cpe:2.3:a:hitachienergy:lumada_apm:6.3.0.0:*:*:*:*:*:*:* * cpe:2.3:a:hitachienergy:lumada_apm:6.4.0.0:*:*:*:*:*:*:*
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| Hitachi EnergyCNA (assigner) | 3.1 | Medium5.7 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N |
| NVDNVD · Modified | 3.1 | High7.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.38% · top 68% of all CVEs (5 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.7.
Weakness
Affected products
- affected 6.0.0.*
- affected 6.1.0.*
- affected 6.2.0.*
- affected 6.3.0.*
- affected 6.4.0.0
- unaffected 6.4.0.1
- unaffected 6.5.0.0
What to do
Solution: * For Lumada APM version 6.4.0.* – Update to Lumada APM version 6.4.0.1, or upgrade to Lumada APM version 6.5.0.0 (or newer). * For Lumada APM versions prior to 6.4.0.0 – Upgrade to Lumada APM version 6.4.0.1 or 6.5.0.0 or newer.
Workaround: Out-of-the-box, Lumada APM – On Premise does not support the Power BI integration feature. Nonetheless, one can connect a subscription-based Power BI to Lumada APM. * In case the Power BI integration feature is enabled, it is recommended to either disable the unsupported Power BI integration feature if there are users with “Limited Engineer” role, or to remove any users with “Limited Engineer” role or to assign those users to other role prior to using the unsupported Power BI integration feature. * If Power BI integration is disabled, it is safe to continue to assign the “Limited Engineer” role to users. Apply general mitigation factors as described in the respective advisory.
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-2155)Record last updated .