Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2022-22162

Junos OS: A low privileged user can elevate their privileges to the ones of the highest privileged j-web user logged in

High7.3EPSS 0.24%
Published
Updated
Reserved
Assigned by
juniper

Description

A Generation of Error Message Containing Sensitive Information vulnerability in the CLI of Juniper Networks Junos OS allows a locally authenticated attacker with low privileges to elevate these to the level of any other user logged in via J-Web at this time, potential leading to a full compromise of the device. This issue affects Juniper Networks Junos OS: All versions prior to 15.1R7-S11; 18.3 versions prior to 18.3R3-S6; 18.4 versions prior to 18.4R2-S9, 18.4R3-S10; 19.1 versions prior to 19.1R2-S3, 19.1R3-S7; 19.2 versions prior to 19.2R1-S8, 19.2R3-S4; 19.3 versions prior to 19.3R3-S4; 19.4 versions prior to 19.4R3-S6; 20.1 versions prior to 20.1R3-S2; 20.2 versions prior to 20.2R3-S3; 20.3 versions prior to 20.3R3-S1; 20.4 versions prior to 20.4R3-S1; 21.1 versions prior to 21.1R2-S1, 21.1R3; 21.2 versions prior to 21.2R1-S1, 21.2R2.

Scores

CVSS scores of CVE-2022-22162, by who scored it
Scored byCVSSScoreVector
juniperCNA (assigner)3.1High7.3CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
NVDNVD · Modified3.1High7.8CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
0.24% · top 84% of all CVEs (6 Nov 2026)
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.3.

Weakness

Affected products

  • Juniper Networks · Junos OS

    • affected unspecified – < 15.1R7-S11
    • affected 18.3 – < 18.3R3-S6
    • affected 18.4 – < 18.4R2-S9, 18.4R3-S10
    • affected 19.1 – < 19.1R2-S3, 19.1R3-S7
    • affected 19.2 – < 19.2R1-S8, 19.2R3-S4
    • affected 19.3 – < 19.3R3-S4
    • affected 19.4 – < 19.4R3-S6
    • affected 20.1 – < 20.1R3-S2
    • affected 20.2 – < 20.2R3-S3
    • affected 20.3 – < 20.3R3-S1
    • affected 20.4 – < 20.4R3-S1
    • affected 21.1 – < 21.1R2-S1, 21.1R3
    • affected 21.2 – < 21.2R1-S1, 21.2R2

What to do

Solution: The following software releases have been updated to resolve this specific issue: 15.1R7-S11, 18.3R3-S6, 18.4R2-S9, 18.4R3-S10, 19.1R2-S3, 19.1R3-S7, 19.2R1-S8, 19.2R3-S4, 19.3R3-S4, 19.4R3-S6, 20.1R3-S2, 20.2R3-S3, 20.3R3-S1, 20.4R3-S1, 21.1R2-S1, 21.1R3, 21.2R1-S1, 21.2R2, 21.3R1, and all subsequent releases.

Workaround: There are no viable workarounds for this issue other than disabling J-Web. To reduce the risk of exploitation of this issue, use access lists or firewall filters to limit access to only trusted administrative networks, hosts and users.

Exploitation: Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2022-22162 badge
[![CVE-2022-22162](https://trackcve.app/badge/CVE-2022-22162.svg)](https://trackcve.app/cve/CVE-2022-22162)

Record last updated .