CVE-2022-22305
An improper certificate validation vulnerability [CWE-295] in FortiManager 7.0.1 and below, 6.4.6 and below; FortiAnalyzer 7.0.2 and…
- Published
- Updated
- Reserved
- Assigned by
- fortinet
Description
An improper certificate validation vulnerability [CWE-295] in FortiManager 7.0.1 and below, 6.4.6 and below; FortiAnalyzer 7.0.2 and below, 6.4.7 and below; FortiOS 6.2.x and 6.0.x; FortiSandbox 4.0.x, 3.2.x and 3.1.x may allow a network adjacent and unauthenticated attacker to man-in-the-middle the communication between the listed products and some external peers.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| fortinetCNA (assigner) | 3.1 | Medium5.4 | CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:U/RC:C |
| NVDNVD · Modified | 3.1 | Medium4.2 | CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.48% · top 58% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.4.
Weakness
Affected products
- affected 7.0.0 – ≤ 7.0.2
- affected 6.4.0 – ≤ 6.4.7
- affected 6.2.0 – ≤ 6.2.11
- affected 6.0.0 – ≤ 6.0.12
- affected 4.0.0 – ≤ 4.0.2
- affected 3.2.0 – ≤ 3.2.4
- affected 3.1.0 – ≤ 3.1.5
- affected 3.0.0 – ≤ 3.0.7
- affected 7.0.0 – ≤ 7.0.1
- affected 6.4.0 – ≤ 6.4.6
- affected 6.2.0 – ≤ 6.2.11
- affected 6.0.0 – ≤ 6.0.12
What to do
Solution: Please upgrade to FortiManager version 7.0.2 or above. Please upgrade to FortiManager version 6.4.7 or above. Please upgrade to FortiAnalyzer version 7.0.3 or above. Please upgrade to FortiAnalyzer version 6.4.8 or above. Please upgrade to FortiSandbox version 4.2.0 or above
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-22305)Record last updated .