Skip to content
TrackCVE
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2022-23504

TYPO3 contains Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration

Medium5.7EPSS 0.55%
Published
Updated
Reserved
Assigned by
GitHub_M

Description

TYPO3 is an open source PHP based web content management system. Versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are subject to Sensitive Information Disclosure. Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. This issue has been patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Timeline

  1. ID reserved

    By GitHub_M

  2. · 11 months later

    Published

  3. · 2 years later

    Record updated

Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.

Scores

CVSS scores of CVE-2022-23504, by who scored it
Scored byCVSSScoreVector
GitHub_MCNA (assigner)3.1Medium5.7CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:L
NVDNVD · Modified3.1Medium4.9CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS (exploitation in 30 days)
0.55% · top 54% of all CVEs (7 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 5.7.

Weakness

Affected products

  • TYPO3 · typo3

    • affected >= 9.0.0, < 9.5.38
    • affected >= 10.0.0, < 10.4.33
    • affected >= 11.0.0, < 11.5.20
    • affected >= 12.0.0, < 12.1.1

Affected packages

From reviewed advisories of the GitHub Advisory Database.

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2022-23504 badge
[![CVE-2022-23504](https://trackcve.app/badge/CVE-2022-23504.svg)](https://trackcve.app/cve/CVE-2022-23504)

Record last updated .