CVE-2022-24280
Apache Pulsar Proxy target broker address isn't validated
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.
Timeline
ID reserved
By apache
- 8 months later
· 8 months later
Published
- 3 years later
· 3 years later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | Medium6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H |
| NVDNVD · Modified | 3.1 | Medium6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H |
- EPSS (exploitation in 30 days)
- 1.5% · top 26% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.5.
Weakness
Affected products
Apache Software Foundation · Apache Pulsar
- affected 2.7 – ≤ 2.7.4
- affected 2.8 – ≤ 2.8.2
- affected 2.9 – ≤ 2.9.1
- affected 2.6 and earlier – ≤ 2.6.4
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.pulsar:pulsarGHSA-3mg9-m3f6-v7fq (opens in a new tab)
What to do
Workaround: To address the issue, upgraded versions of Apache Pulsar Proxy will only allow connections to known broker ports 6650 and 6651 by default. In addition, it is necessary to limit proxied broker connections further to known broker addresses by specifying brokerProxyAllowedHostNames and brokerProxyAllowedIPAddresses Pulsar Proxy settings. In Pulsar Helm chart deployments, the setting names should be prefixed with "PULSAR_PREFIX_". 2.7 users should upgrade Pulsar Proxies to 2.7.5 and apply configuration changes. 2.8 users should upgrade Pulsar Proxies to at least 2.8.3 and apply configuration changes. 2.9 users should upgrade Pulsar Proxies to at least 2.9.2 and apply configuration changes. 2.10 users should apply configuration changes. Any users running the Pulsar Proxy 2.6.4 and earlier should upgrade to one of the above patched versions and apply configuration changes.
References (1)
- https://lists.apache.org/thread/ghs9jtjfbpy4c6xcftyvkl6swznlom1v (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-3mg9-m3f6-v7fq (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-24280)Record last updated .