CVE-2022-24697
Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| CISA-ADPADP (enrichment) | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
| NVDNVD · Modified | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 84.8% · top 0.3% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: yes · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.8.
Weakness
Affected products
Apache Software Foundation · Apache Kylin
- affected Apache Kylin 2 – < 2.6.6
- affected Apache Kylin 3 – ≤ 3.1.2
- affected Apache Kylin 4 – ≤ 4.0.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.kylin:kylin-core-commonGHSA-ppxx-m926-g569 (opens in a new tab)
- Mavenorg.apache.kylin:kylin-server-baseGHSA-ppxx-m926-g569 (opens in a new tab)
- Mavenorg.apache.kylin:kylin-spark-projectGHSA-ppxx-m926-g569 (opens in a new tab)
What to do
Workaround: Users of Kylin 2.x & Kylin 3.x & 4.x should upgrade to 4.0.2 or apply patch https://github.com/apache/kylin/pull/1811 .
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-ppxx-m926-g569 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-24697)Record last updated .