CVE-2022-24822
Denial of Service in @podium/layout and @podium/proxy
- Published
- Updated
- Reserved
- Assigned by
- GitHub_M
Description
Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.
Timeline
ID reserved
By GitHub_M
- 55 days later
· 55 days later
Published
- 3 years later
· 3 years later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitHub_MCNA (assigner) | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H |
| NVDNVD · Modified | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H |
- EPSS (exploitation in 30 days)
- 1.7% · top 23% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: yes · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.5.
Weakness
Affected products
- affected < 4.6.110
- affected < 4.2.74
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- npm@podium/layoutGHSA-3hjg-vc7r-rcrw (opens in a new tab)
- npm@podium/proxyGHSA-3hjg-vc7r-rcrw (opens in a new tab)
References (5)
- https://github.com/podium-lib/proxy/security/advisories/GHSA-3hjg-vc7r-rcrw (opens in a new tab)x_refsource_CONFIRMx_transferred
- https://github.com/podium-lib/layout/commit/fe43e655432b0a5f07b6475f67babcc2588fb039 (opens in a new tab)x_refsource_MISCx_transferred
- https://github.com/podium-lib/proxy/commit/9698a40df081217ce142d4de71f929baaa339cdf (opens in a new tab)x_refsource_MISCx_transferred
- https://github.com/podium-lib/layout/releases/tag/v4.6.110 (opens in a new tab)x_refsource_MISCx_transferred
- https://github.com/podium-lib/proxy/releases/tag/v4.2.74 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-3hjg-vc7r-rcrw (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-24822)Record last updated .