Back
CVE-2022-24947
Apache JSPWiki CSRF Account Takeover
High8.8EPSS 1.2%
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover. Apache JSPWiki users should upgrade to 2.11.2 or later.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | High8.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 1.2% · top 33% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.8.
Weakness
- CSRF Account Takeover
- CWE-352 (opens in a new tab)All about CWE-352 and its CVEs
Affected products
Apache Software Foundation · Apache JSPWiki
- affected Apache JSPWiki up to 2.11.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.jspwiki:jspwiki-mainGHSA-4284-x26r-4hhc (opens in a new tab)
What to do
Workaround: Installations >= 2.7.0 can also enable user management workflows' manual approval to mitigate the issue.
References (2)
- https://lists.apache.org/thread/txrgykjkpt80t57kzpbjo8kfrv8ss02c (opens in a new tab)x_refsource_MISCx_transferred
- [oss-security] 20220225 [CVE-2022-24947] Apache JSPWiki CSRF Account Takeover (opens in a new tab)mailing-listx_refsource_MLISTx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-4284-x26r-4hhc (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-24947)Record last updated .