Back
CVE-2022-24948
Apache JSPWiki Cross-site scripting vulnerability on User Preferences screen
Medium6.1EPSS 2.3%
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
A carefully crafted user preferences for submission could trigger an XSS vulnerability on Apache JSPWiki, related to the user preferences screen, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.2 or later.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | Medium6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 2.3% · top 17% of all CVEs (6 Nov 2026)
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.1.
Weakness
- Cross-site scripting vulnerability on User Preferences screen
- CWE-79 (opens in a new tab)All about CWE-79 and its CVEs
Affected products
Apache Software Foundation · Apache JSPWiki
- affected Apache JSPWiki up to 2.11.1
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.jspwiki:jspwiki-mainGHSA-9953-fmrw-v4vm (opens in a new tab)
References (2)
- https://lists.apache.org/thread/86p0yzopc4mw2h5bkwpt927b2c8tfq3b (opens in a new tab)x_refsource_MISCx_transferred
- [oss-security] 20220225 [CVE-2022-24948] Apache JSPWiki Cross-site scripting vulnerability on User Preferences screen (opens in a new tab)mailing-listx_refsource_MLISTx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-9953-fmrw-v4vm (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-24948)Record last updated .