CVE-2022-28732
Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
A carefully crafted request on WeblogPlugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.3 or later.
Timeline
ID reserved
By apache
- 4 months later
· 4 months later
Published
- 2 years later
· 2 years later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | Medium6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 82.8% · top 0.3% of all CVEs (7 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.1.
Weakness
Affected products
Apache Software Foundation · Apache JSPWiki
- affected Apache JSPWiki – ≤ Apache JSPWiki up to 2.11.2
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.jspwiki:jspwiki-mainGHSA-hph8-29xw-qfxx (opens in a new tab)
References (1)
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732 (opens in a new tab)x_refsource_MISCx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-hph8-29xw-qfxx (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-28732)Record last updated .