Back
CVE-2022-29418
WordPress Night Mode plugin <= 1.0.0 - Authenticated Persistent Cross-Site Scripting (XSS) vulnerability
Medium4.8EPSS 0.54%
- Published
- Updated
- Reserved
- Assigned by
- Patchstack
Description
Authenticated (admin user role) Persistent Cross-Site Scripting (XSS) in Mark Daniels Night Mode plugin <= 1.0.0 on WordPress via vulnerable parameters: &ntmode_page_setting[enable-me], &ntmode_page_setting[bg-color], &ntmode_page_setting[txt-color], &ntmode_page_setting[anc_color].
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| PatchstackCNA (assigner) | 3.1 | Medium4.8 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N |
| NVDNVD · Modified | 3.1 | Medium4.8 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.54% · top 54% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.8.
Weakness
Affected products
Mark Daniels · Night Mode (WordPress plugin)
- affected <= 1.0.0 – ≤ 1.0.0
What to do
Solution: Update to 1.4.0 or higher version.
References (2)
- https://wordpress.org/plugins/night-mode/#developers (opens in a new tab)x_refsource_CONFIRMx_transferred
- https://patchstack.com/database/vulnerability/night-mode/wordpress-night-mode-plugin-1-0-0-authenticated-persistent-cross-site-scripting-xss-vulnerability (opens in a new tab)x_refsource_CONFIRMx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-29418)Record last updated .