CVE-2022-33980
Apache Commons Configuration insecure interpolation defaults
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.
Timeline
ID reserved
By apache
- 18 days later
· 18 days later
Published
- 2 years later
· 2 years later
Record updated
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| NVDNVD · Modified | 3.1 | Critical9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 44.6% · top 1.2% of all CVEs (7 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.8.
Weakness
- Insecure interpolation defaults
Affected products
Apache Software Foundation · Apache Commons Configuration
- affected Apache Commons Configuration – < 2.8.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.commons:commons-configuration2GHSA-xj57-8qj4-c4m6 (opens in a new tab)
What to do
Workaround: Upgrade to version Apache Commons Configuration 2.8.0
References (5)
- https://lists.apache.org/thread/tdf5n7j80lfxdhs2764vn0xmpfodm87s (opens in a new tab)x_transferred
- [oss-security] 20220706 CVE-2022-33980: Apache Commons Configuration insecure interpolation defaults (opens in a new tab)mailing-listx_transferred
- https://security.netapp.com/advisory/ntap-20221028-0015/ (opens in a new tab)x_transferred
- [oss-security] 20221115 Multiple vulnerabilities in Jenkins plugins (opens in a new tab)mailing-listx_transferred
- DSA-5290 (opens in a new tab)vendor-advisoryx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-xj57-8qj4-c4m6 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-33980)Record last updated .