Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2022-35845

Multiple improper neutralization of special elements used in an OS Command ('OS Command Injection') vulnerabilities [CWE-78] in…

High7.6EPSS 1.1%
Published
Updated
Reserved
Assigned by
fortinet

Description

Multiple improper neutralization of special elements used in an OS Command ('OS Command Injection') vulnerabilities [CWE-78] in FortiTester 7.1.0, 7.0 all versions, 4.0.0 through 4.2.0, 2.3.0 through 3.9.1 may allow an authenticated attacker to execute arbitrary commands in the underlying shell.

Scores

CVSS scores of CVE-2022-35845, by who scored it
Scored byCVSSScoreVector
fortinetCNA (assigner)3.1High7.6CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F/RL:U/RC:C
NVDNVD · Modified3.1High8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS (exploitation in 30 days)
1.1% · top 33% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.6.

Weakness

Affected products

  • Fortinet · FortiTester

    • affected 7.1.0
    • affected 7.0.0
    • affected 4.2.0
    • affected 4.1.0 – ≤ 4.1.1
    • affected 4.0.0
    • affected 3.9.0 – ≤ 3.9.1
    • affected 3.8.0
    • affected 3.7.0 – ≤ 3.7.1
    • affected 3.6.0
    • affected 3.5.0 – ≤ 3.5.1
    • affected 3.4.0
    • affected 3.3.0 – ≤ 3.3.1
    • affected 3.2.0
    • affected 3.1.0
    • affected 3.0.0
    • affected 2.9.0
    • affected 2.8.0
    • affected 2.7.0
    • affected 2.6.0
    • affected 2.5.0
    • affected 2.4.0 – ≤ 2.4.1
    • affected 2.3.0

What to do

Solution: Please upgrade to FortiTester version 7.2.0 or above Please upgrade to FortiTester version 7.1.1 or above Please upgrade to FortiTester version 4.2.1 or above Please upgrade to FortiTester version 3.9.2 or above

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2022-35845 badge
[![CVE-2022-35845](https://trackcve.app/badge/CVE-2022-35845.svg)](https://trackcve.app/cve/CVE-2022-35845)

Record last updated .