Back
CVE-2022-4045
Authenticated user could send multiple requests containing a parameter which could fetch a large amount of data and can crash a Mattermost server
Low3.1EPSS 0.65%
- Published
- Updated
- Reserved
- Assigned by
- Mattermost
Description
A denial-of-service vulnerability in the Mattermost allows an authenticated user to crash the server via multiple requests to one of the API endpoints which could fetch a large amount of data.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| MattermostCNA (assigner) | 3.1 | Low3.1 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L |
| NVDNVD · Modified | 3.1 | Medium6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H |
- EPSS (exploitation in 30 days)
- 0.65% · top 49% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 3.1.
Weakness
Affected products
- affected < 7.3.*
- unaffected 7.4.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Gogithub.com/mattermost/mattermost-serverGHSA-v42f-hq78-8c5m (opens in a new tab)
What to do
Solution: Update Mattermost to version v7.4.0 or higher.
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-v42f-hq78-8c5m (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-4045)Record last updated .