CVE-2022-41558
TIBCO Spotfire Stored Cross Site Scripting (XSS) Vulnerability
- Published
- Updated
- Reserved
- Assigned by
- tibco
Description
The Visualizations component of TIBCO Software Inc.'s TIBCO Spotfire Analyst, TIBCO Spotfire Analyst, TIBCO Spotfire Analyst, TIBCO Spotfire Analytics Platform for AWS Marketplace, TIBCO Spotfire Desktop, TIBCO Spotfire Desktop, TIBCO Spotfire Desktop, TIBCO Spotfire Server, TIBCO Spotfire Server, and TIBCO Spotfire Server contains an easily exploitable vulnerability that allows a low privileged attacker with network access to execute Stored Cross Site Scripting (XSS) on the affected system. A successful attack using this vulnerability requires human interaction from a person other than the attacker. Affected releases are TIBCO Software Inc.'s TIBCO Spotfire Analyst: versions 11.4.4 and below, TIBCO Spotfire Analyst: versions 11.5.0, 11.6.0, 11.7.0, 11.8.0, 12.0.0, and 12.0.1, TIBCO Spotfire Analyst: version 12.1.0, TIBCO Spotfire Analytics Platform for AWS Marketplace: versions 12.1.0 and below, TIBCO Spotfire Desktop: versions 11.4.4 and below, TIBCO Spotfire Desktop: versions 11.5.0, 11.6.0, 11.7.0, 11.8.0, 12.0.0, and 12.0.1, TIBCO Spotfire Desktop: version 12.1.0, TIBCO Spotfire Server: versions 11.4.8 and below, TIBCO Spotfire Server: versions 11.5.0, 11.6.0, 11.6.1, 11.6.2, 11.6.3, 11.7.0, 11.8.0, 11.8.1, 12.0.0, and 12.0.1, and TIBCO Spotfire Server: version 12.1.0.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| tibcoCNA (assigner) | 3.1 | Critical9.0 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H |
| NVDNVD · Modified | 3.1 | Medium5.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.54% · top 54% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: total
The list uses the assigner's score when there is one, then CISA's, then NVD's: Critical 9.0.
Weakness
- Successful execution of these vulnerabilities will result in an attacker being able to execute commands with the privileges of the affected user.
- CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') (opens in a new tab)All about CWE-79 and its CVEs
Affected products
TIBCO Software Inc. · TIBCO Spotfire Analyst
- affected unspecified – ≤ 11.4.4
TIBCO Software Inc. · TIBCO Spotfire Analyst
- affected 11.5.0
- affected 11.6.0
- affected 11.7.0
- affected 11.8.0
- affected 12.0.0
- affected 12.0.1
TIBCO Software Inc. · TIBCO Spotfire Analyst
- affected 12.1.0
TIBCO Software Inc. · TIBCO Spotfire Analytics Platform for AWS Marketplace
- affected unspecified – ≤ 12.1.0
TIBCO Software Inc. · TIBCO Spotfire Desktop
- affected unspecified – ≤ 11.4.4
TIBCO Software Inc. · TIBCO Spotfire Desktop
- affected 11.5.0
- affected 11.6.0
- affected 11.7.0
- affected 11.8.0
- affected 12.0.0
- affected 12.0.1
TIBCO Software Inc. · TIBCO Spotfire Desktop
- affected 12.1.0
TIBCO Software Inc. · TIBCO Spotfire Server
- affected unspecified – ≤ 11.4.8
TIBCO Software Inc. · TIBCO Spotfire Server
- affected 11.5.0
- affected 11.6.0
- affected 11.6.1
- affected 11.6.2
- affected 11.6.3
- affected 11.7.0
- affected 11.8.0
- affected 11.8.1
- affected 12.0.0
- affected 12.0.1
TIBCO Software Inc. · TIBCO Spotfire Server
- affected 12.1.0
What to do
Solution: TIBCO has released updated versions of the affected components which address these issues. TIBCO Spotfire Analyst versions 11.4.4 and below: update to version 11.4.5 or later TIBCO Spotfire Analyst versions 11.5.0, 11.6.0, 11.7.0, 11.8.0, 12.0.0, and 12.0.1: update to version 12.0.2 or later TIBCO Spotfire Analyst version 12.1.0: update to version 12.1.1 or later TIBCO Spotfire Analytics Platform for AWS Marketplace versions 12.1.0 and below: update to version 12.1.1 or later TIBCO Spotfire Desktop versions 11.4.4 and below: update to version 11.4.5 or later TIBCO Spotfire Desktop versions 11.5.0, 11.6.0, 11.7.0, 11.8.0, 12.0.0, and 12.0.1: update to version 12.0.2 or later TIBCO Spotfire Desktop version 12.1.0: update to version 12.1.1 or later TIBCO Spotfire Server versions 11.4.8 and below: update to version 11.4.9 or later TIBCO Spotfire Server versions 11.5.0, 11.6.0, 11.6.1, 11.6.2, 11.6.3, 11.7.0, 11.8.0, 11.8.1, 12.0.0, and 12.0.1: update to version 12.0.2 or later TIBCO Spotfire Server version 12.1.0: update to version 12.1.1 or later
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-41558)Record last updated .