CVE-2022-45856
An improper certificate validation vulnerability [CWE-295] in FortiClientWindows 6.4 all versions, 7.0.0 through 7.0.7, FortiClientMac 6.4…
- Published
- Updated
- Reserved
- Assigned by
- fortinet
Description
An improper certificate validation vulnerability [CWE-295] in FortiClientWindows 6.4 all versions, 7.0.0 through 7.0.7, FortiClientMac 6.4 all versions, 7.0 all versions, 7.2.0 through 7.2.4, FortiClientLinux 6.4 all versions, 7.0 all versions, 7.2.0 through 7.2.4, FortiClientAndroid 6.4 all versions, 7.0 all versions, 7.2.0 and FortiClientiOS 5.6 all versions, 6.0.0 through 6.0.1, 7.0.0 through 7.0.6 SAML SSO feature may allow an unauthenticated attacker to man-in-the-middle the communication between the FortiClient and both the service provider and the identity provider.
Timeline
ID reserved
By fortinet
- 22 months later
· 22 months later
Published
Changes after publication (a new score, a public exploit, EPSS crossing 1, 10 or 50 %, leaving KEV) are kept since November 2026; earlier ones are not known.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| fortinetCNA (assigner) | 3.1 | Medium4.6 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N/E:P/RL:U/RC:C |
| NVDNVD · Analyzed | 3.1 | Medium5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N |
- EPSS (exploitation in 30 days)
- 0.23% · top 86% of all CVEs (7 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.6.
Weakness
Affected products
- affected 7.0.3 – ≤ 7.0.6
- affected 7.0.0 – ≤ 7.0.1
- affected 6.0.0 – ≤ 6.0.1
- affected 5.6.5 – ≤ 5.6.6
- affected 5.6.0 – ≤ 5.6.1
- affected 5.4.3 – ≤ 5.4.4
- affected 5.4.0 – ≤ 5.4.1
- affected 5.2.0 – ≤ 5.2.3
- affected 5.0.0 – ≤ 5.0.3
- affected 4.0.0 – ≤ 4.0.2
- affected 2.0.0 – ≤ 2.0.1
- affected 7.2.0
- affected 7.0.6 – ≤ 7.0.7
- affected 7.0.2 – ≤ 7.0.3
- affected 7.0.0
- affected 6.4.6
- affected 6.4.4
- affected 6.4.1
- affected 6.0.0
- affected 5.6.0
- affected 5.4.0 – ≤ 5.4.2
- affected 5.2.0 – ≤ 5.2.8
- affected 5.0.0 – ≤ 5.0.3
- affected 7.2.0 – ≤ 7.2.4
- affected 7.0.0 – ≤ 7.0.13
- affected 6.4.0 – ≤ 6.4.10
- affected 7.2.0 – ≤ 7.2.4
- affected 7.0.0 – ≤ 7.0.13
- affected 6.4.7 – ≤ 6.4.9
- affected 6.4.0 – ≤ 6.4.4
- affected 7.0.0 – ≤ 7.0.7
- affected 6.4.0 – ≤ 6.4.10
What to do
Solution: Please upgrade to FortiClientAndroid version 7.2.1 or above Please upgrade to FortiClientiOS version 7.0.7 or above Please upgrade to FortiClientMac version 7.4.0 or above Please upgrade to FortiClientMac version 7.2.5 or above Please upgrade to FortiClientLinux version 7.4.0 or above Please upgrade to FortiClientLinux version 7.2.5 or above Please upgrade to FortiClientWindows version 7.2.0 or above Please upgrade to FortiClientWindows version 7.0.8 or above
References (1)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-45856)Record last updated .