Skip to content
CVE Tracker
  • Newest CVEsPage
  • Recently added to KEVPage
  • Rising exploitation (EPSS)Page
  • Weekly digestPage
  • StatisticsPage
  • WatchlistPage
  • API documentationPage
  • MCP serverPage
  • Data sourcesPage
  • ChangelogPage
  • AboutPage
  • How it's builtPage
Back

CVE-2022-45858

A use of a weak cryptographic algorithm vulnerability [CWE-327] in FortiNAC 9.4.1 and below, 9.2.6 and below, 9.1.0 all versions, 8.8.0…

Low3.8EPSS 0.20%
Published
Updated
Reserved
Assigned by
fortinet

Description

A use of a weak cryptographic algorithm vulnerability [CWE-327] in FortiNAC 9.4.1 and below, 9.2.6 and below, 9.1.0 all versions, 8.8.0 all versions, 8.7.0 all versions may increase the chances of an attacker to have access to sensitive information or to perform man-in-the-middle attacks.

Scores

CVSS scores of CVE-2022-45858, by who scored it
Scored byCVSSScoreVector
fortinetCNA (assigner)3.1Low3.8CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P/RL:U/RC:R
NVDNVD · Modified3.1High7.4CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS (exploitation in 30 days)
0.20% · top 90% of all CVEs (6 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 3.8.

Weakness

Affected products

  • Fortinet · FortiNAC

    • affected 9.4.0 – ≤ 9.4.1
    • affected 9.2.0 – ≤ 9.2.6
    • affected 9.1.0 – ≤ 9.1.9
    • affected 8.8.0 – ≤ 8.8.11
    • affected 8.7.0 – ≤ 8.7.6
    • affected 7.2.0

What to do

Solution: Please upgrade to FortiNAC-F version 7.2.1 or above Please upgrade to FortiNAC version 9.4.2 or above Please upgrade to FortiNAC version 9.2.7 or above

References (1)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2022-45858 badge
[![CVE-2022-45858](https://trackcve.app/badge/CVE-2022-45858.svg)](https://trackcve.app/cve/CVE-2022-45858)

Record last updated .