Back
CVE-2022-4876
Kaltura mwEmbed DefaultSettings.php cross site scripting
Low3.5EPSS 0.54%
- Published
- Updated
- Reserved
- Assigned by
- VulDB
Description
A vulnerability was found in Kaltura mwEmbed up to 2.96.rc1 and classified as problematic. This issue affects some unknown processing of the file includes/DefaultSettings.php. The manipulation of the argument HTTP_X_FORWARDED_HOST leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.96.rc2 is able to address this issue. The patch is named 13b8812ebc8c9fa034eed91ab35ba8423a528c0b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217427.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| VulDBCNA (assigner) | 3.1 | Low3.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N |
| VulDBCNA (assigner) | 3.0 | Low3.5 | CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N |
| VulDBCNA (assigner) | 2.0 | Medium4.0 | AV:N/AC:L/Au:S/C:N/I:P/A:N |
| NVDNVD · Modified | 3.1 | Medium6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.54% · top 54% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Low 3.5.
Weakness
Affected products
References (5)
- https://vuldb.com/?id.217427 (opens in a new tab)vdb-entrytechnical-descriptionx_transferred
- https://vuldb.com/?ctiid.217427 (opens in a new tab)signaturepermissions-requiredx_transferred
- https://github.com/kaltura/mwEmbed/pull/4266 (opens in a new tab)issue-trackingx_transferred
- https://github.com/kaltura/mwEmbed/commit/13b8812ebc8c9fa034eed91ab35ba8423a528c0b (opens in a new tab)patchx_transferred
- https://github.com/kaltura/mwEmbed/releases/tag/v2.96.rc2 (opens in a new tab)patchx_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2022-4876)Record last updated .