CVE-2023-0867
Multiple stored and reflected Cross-site Scripting in webapp
- Published
- Updated
- Reserved
- Assigned by
- OpenNMS
Description
Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| OpenNMSCNA (assigner) | 3.1 | Medium6.7 | CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N |
| NVDNVD · Modified | 3.1 | Medium6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
- EPSS (exploitation in 30 days)
- 0.42% · top 63% of all CVEs (6 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.7.
Weakness
Affected products
- affected 2020.1.0 – < 2020.1.32
- affected 2021.1.0 – < 2021.1.24
- affected 2022.1.0 – < 2022.1.13
- unaffected 2023.1.0
- affected 26.0.0 – < 31.0.4
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.opennms:opennmsGHSA-mjv2-6jv4-vrg7 (opens in a new tab)
What to do
Solution: Upgrade to a newer version of Meridian or Horizon.
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-mjv2-6jv4-vrg7 (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-0867)Record last updated .