CVE-2023-0872
ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users
- Published
- Updated
- Reserved
- Assigned by
- OpenNMS
Description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| OpenNMSCNA (assigner) | 3.1 | High8.2 | CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L |
| NVDNVD · Modified | 3.1 | High8.0 | CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 3.3% · top 11% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: partial
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 8.2.
Weakness
Affected products
- affected 31.0.8 – < 32.0.2
- unknown < 31.0.8
- affected 2020.0.0 – ≤ 2020.1.37
- affected 2021.0.0 – ≤ 2021.1.29
- affected 2022.0.0 – ≤ 2022.1.18
- affected 2023.0.0 – ≤ 2023.1.5
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.opennms:opennms-webapp-restGHSA-w5gq-xrrp-3fxf (opens in a new tab)
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-w5gq-xrrp-3fxf (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-0872)Record last updated .