Skip to content
CVE Tracker
Back

CVE-2023-28107

Discourse vulnerable to multisite DoS by spamming backups

Medium4.5EPSS 0.65%
Published
Updated
Reserved
Assigned by
GitHub_M

Description

Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.

Scores

CVSS scores of CVE-2023-28107, by who scored it
Scored byCVSSScoreVector
GitHub_MCNA (assigner)3.1Medium4.5CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H
NVDNVD · Modified3.1Medium4.9CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
EPSS (exploitation in 30 days)
0.65% · top 49% of all CVEs (3 Nov 2026)
CISA SSVC
Exploitation: none · Automatable: no · Technical impact: partial
Loading the EPSS history…

The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 4.5.

Weakness

Affected products

  • discourse · discourse

    • affected stable < 3.0.2
    • affected beta < 3.1.0.beta3
    • affected tests-passed < 3.1.0.beta3

References (5)

Sources

The same CVE in the primary databases and aggregators, to check against.

Badge for a README or a ticket

CVE-2023-28107 badge
[![CVE-2023-28107](https://trackcve.app/badge/CVE-2023-28107.svg)](https://trackcve.app/cve/CVE-2023-28107)

Record last updated .