Back
CVE-2023-3441
Exposure of Sensitive Information Due to Incompatible Policies in GitLab
Medium6.6EPSS 0.55%
- Published
- Updated
- Reserved
- Assigned by
- GitLab
Description
An issue has been discovered in GitLab EE/CE affecting all versions starting from 8.0 before 16.4. The product did not sufficiently warn about security implications of granting merge rights to protected branches.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| GitLabCNA (assigner) | 3.1 | Medium6.6 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:N |
| NVDNVD · Analyzed | 3.1 | Critical9.1 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.55% · top 54% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: poc · Automatable: no · Technical impact: partial
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: Medium 6.6.
Weakness
Affected products
What to do
Solution: Upgrade to versions 16.4 or above.
References (4)
- GitLab Issue #416482 (opens in a new tab)issue-trackingpermissions-required
- HackerOne Bug Bounty Report #2033561 (opens in a new tab)technical-descriptionexploitpermissions-required
- GitLab Issue #417284 (opens in a new tab)issue-trackingpermissions-required
- HackerOne Bug Bounty Report #2041385 (opens in a new tab)technical-descriptionexploitpermissions-required
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisories (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-3441)Record last updated .