CVE-2023-37544
Apache Pulsar WebSocket Proxy: Improper Authentication for WebSocket Proxy Endpoint Allows DoS
- Published
- Updated
- Reserved
- Assigned by
- apache
Description
Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication. This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8.*, from 2.9.0 through 2.9.*, from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0. The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature. 2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5. 2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2. 3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1. 3.1 Pulsar WebSocket Proxy users are unaffected. Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| apacheCNA (assigner) | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H |
| NVDNVD · Modified | 3.1 | High7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H |
- EPSS (exploitation in 30 days)
- 1.4% · top 28% of all CVEs (6 Nov 2026)
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.5.
Weakness
Affected products
Apache Software Foundation · Apache Pulsar WebSocket Proxy
- affected 2.8.0 – ≤ 2.8.*
- affected 2.9.0 – ≤ 2.9.*
- affected 2.10.0 – ≤ 2.10.4
- affected 2.11.0 – ≤ 2.11.1
- affected 3.0.0
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.apache.pulsar:pulsar-websocketGHSA-83q5-whqp-r8jr (opens in a new tab)
References (2)
- https://lists.apache.org/thread/od0k9zts1toc9h9snbqq4pjpyx28mv4m (opens in a new tab)vendor-advisoryx_transferred
- http://www.openwall.com/lists/oss-security/2023/12/20/2 (opens in a new tab)x_transferred
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-83q5-whqp-r8jr (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-37544)Record last updated .