Back
CVE-2023-40313
Disable BeanShell Interpreter Remote Server Mode
High7.1EPSS 0.78%
- Published
- Updated
- Reserved
- Assigned by
- OpenNMS
Description
A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Scores
| Scored by | CVSS | Score | Vector |
|---|---|---|---|
| OpenNMSCNA (assigner) | 3.1 | High7.1 | CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L |
| NVDNVD · Modified | 3.1 | High8.8 | CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
- EPSS (exploitation in 30 days)
- 0.78% · top 44% of all CVEs (6 Nov 2026)
- CISA SSVC
- Exploitation: none · Automatable: no · Technical impact: total
Loading the EPSS history…
The list uses the assigner's score when there is one, then CISA's, then NVD's: High 7.1.
Weakness
Affected products
- affected 29.0.4 – < 32.0.2
- unknown < 29.0.4
- affected 2020.0.0 – ≤ 2020.1.37
- affected 2021.0.0 – ≤ 2021.1.29
- affected 2022.0.0 – ≤ 2022.1.18
- affected 2023.0.0 – ≤ 2023.1.5
Affected packages
From reviewed advisories of the GitHub Advisory Database.
- Mavenorg.opennms:opennms-base-assemblyGHSA-5m5f-qg8r-p9qf (opens in a new tab)
References (2)
Sources
The same CVE in the primary databases and aggregators, to check against.
- CVE.org record (opens in a new tab)
- CVE List JSON (GitHub) (opens in a new tab)
- NVD (opens in a new tab)
- FIRST EPSS (opens in a new tab)
- OSV.dev (opens in a new tab)
- GitHub Advisory GHSA-5m5f-qg8r-p9qf (opens in a new tab)
- CIRCL Vulnerability-Lookup (opens in a new tab)
Badge for a README or a ticket
[](https://trackcve.app/cve/CVE-2023-40313)Record last updated .